Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

View previous topic View next topic Go down

Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  Jmlevick on Sat May 28, 2011 2:48 am

Since I bought my computer and I installed Linux on it, I had this problem...
Back in the day I never Found a REAL Solution and finally my "solution" (in Fedora)
was installing "pavucontrol" to choose the Devices when I needed to Switch.

Via the Pulse Audio Volume Control I was able to Mute speakers or Headphones
at my will, even if I had both connected, this thing worked from F12 to F14 very well...

(The same problem is present in every distro I tried and sometimes it was solved the
same way in other distros)

But Now, I'm in F15 And my magic workout doesn't work anymore... it doesn't matter
wich device I choose as output, the PC simply don't mute one or another and my headphones
and speakers sound at the same time, Can you tell me How to Fix it?

The Sound card is a HDA INTEL with the Realtek ALC662 rev1 Chip, as I said before,
I'm using Fedora 15 KDE (64 Bit version) and I'm running ALSA v 1.0.23 with pulseaudio 0.9.22-5
The output of "lsmod | grep snd" is:

snd_usb_audio 98871 1
snd_usbmidi_lib 18066 1 snd_usb_audio
snd_rawmidi 20308 1 snd_usbmidi_lib
snd_hda_codec_realtek 325262 1
snd_hda_intel 23694 3
snd_hda_codec 80822 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 6368 2 snd_usb_audio,snd_hda_codec
snd_seq 52438 0
snd_seq_device 6001 2 snd_rawmidi,snd_seq
snd_pcm 78484 4 snd_usb_audio,snd_hda_intel,snd_hda_codec
snd_timer 19593 2 snd_seq,snd_pcm
snd 62686 18
snd_usb_audio,snd_usbmidi_lib,snd_rawmidi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
soundcore 6299 1 snd
snd_page_alloc 7431 2 snd_hda_intel,snd_pcm

I've already filed a bug, googled a lot, write e-mail to lists, asked to some people and NO ONE has a Solution for this,

Any Help will be really nice

Thanks!

P.S. The Bug Report is here: https://bugzilla.redhat.com/show_bug.cgi?id=708557

--
<-Manuel Escudero->
Linux User #509052
@GWave: jmlevick@googlewave.com
@Blogger: http://www.blogxenode.tk/ (Xenode Systems Blog)
PGP/GnuPG: E2B4 31CE F2BF 1944 8664 3E22 88C8 DFC9 4D7C 1B35

Jmlevick

Posts : 10
Join date : 2011-05-28

View user profile

Back to top Go down

Re: Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  kaddy on Sat May 28, 2011 4:43 am

hi Jmlevick, Welcome

Yeah that sounds like a bug that I doubt I can find a workaround for....hmmmmm

I tested my F15 install aswell and I can't get any playback through my headphones, only my pc speakers.... so there is definately a bug there... It works for me
on Arch.... although I don't think I have tested it in a while, maybe a new kernel update wrecked something... either that or it is pulse audio......

You could try opening a terminal and typing in "alsamixer" and you can pick f6 and choose a device.... try and choose your headphone device (if it lets you) and see if you can enable it and mute it etc......

That is about all I can think of man.......
avatar
kaddy
Admin

Posts : 248
Join date : 2011-01-26

View user profile http://linux4unme.forumotion.com

Back to top Go down

Re: Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  waynefoutz on Sat May 28, 2011 7:40 am

kaddy wrote:

I tested my F15 install aswell and I can't get any playback through my headphones, only my pc speakers.... so there is definately a bug there... It works for me
on Arch.... although I don't think I have tested it in a while, maybe a new kernel update wrecked something... either that or it is pulse audio......


That ain't good news. My laptop's internal speakers bit the dust about six months ago, faulty headphone jack. The only sound I can get out of it is through the headphone jack, or the USB port.

alsamixer should do the job here, but it's an ugly solution.
avatar
waynefoutz

Posts : 117
Join date : 2011-01-28

View user profile

Back to top Go down

Re: Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  kaddy on Sat May 28, 2011 7:48 am

lol yer.... ohwell... hopefully you get a response to your bug report too from somebody who will know
more about this.... Shocked
avatar
kaddy
Admin

Posts : 248
Join date : 2011-01-26

View user profile http://linux4unme.forumotion.com

Back to top Go down

Re: Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  Jmlevick on Sat May 28, 2011 12:02 pm

@Kaddy: thanks, yep, I think it's a problem with pulseaudio... I think, the solution
is to remove pulseaudio and install the lastest Realtek Linux Audio Pack but in Fedora
we do not have the proper configuration files for alsa and everything related with sound
is different than in, (for example) ubuntu, So I won't try to do this I'm telling you
because I'm afraid I'll "mess up" my Sound (did it once) and I do not have time to
reinstall, need to work.

In theory and just in theory, Removing Pulseaudio and only keeping ALSA
with an ".asoundarc" file inside my home folder (with the right config) may be the
solution but I'm not testing it until I'm sure.

P.S. Alsamixer only let me choose for sound cards, not output devices and
even when I "store" the settings I want, everything "mess up" after a reboot, so it's
not helpful here Crying or Very sad

Jmlevick

Posts : 10
Join date : 2011-05-28

View user profile

Back to top Go down

Re: Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  Jmlevick on Sat May 28, 2011 3:20 pm

An Update to my issue:

Just Now I tried to use the Pulse Audio Volume Control again to
select the output and if I select the speakers, both headphones and speakers sound
BUT if I select Headphones BOTH devices "shut up" O.o ¿Why?

¿Any ideas?

Jmlevick

Posts : 10
Join date : 2011-05-28

View user profile

Back to top Go down

Re: Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  kaddy on Sat May 28, 2011 7:34 pm

LoL yeah that wouldn't suprise me... unfortunately it is a Bug with Pulse-audio
which is out of my control...... I suppose if you were desperate you could find an older pulseaudio package from F14 and try to install that instead (if the deps let you)

oh the joys of using a bleeding edge distro Mad

I wish I had an easy solution for you.... but I don't.... oh wait, yes I do... install archlinux Wink muhahaha

Let us know what you end up doing anyways or if you end up finding a workaround Smile

avatar
kaddy
Admin

Posts : 248
Join date : 2011-01-26

View user profile http://linux4unme.forumotion.com

Back to top Go down

Re: Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  jonathan on Sat May 28, 2011 8:11 pm

If you use gnome 3 on arch then you'll have to use pulse. I think I had somewhere on the arch site that gnome 3 will now require pulse.

jonathan

Posts : 92
Join date : 2011-01-26

View user profile

Back to top Go down

Re: Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  kaddy on Sat May 28, 2011 10:11 pm

That is true... If you use Gnome 3, yes.... actually I should check if My headphones work... the pulseaudio package verison is likely to be different than fedora's... i'll try and get back to ya

edit
Just tried ArchLinux and my headphones work where as they don't on Fedora...
I have pulseaudio 0.9.22-2 on Arch........ forgot what version was on fedora... I think it was 1 before that version...

so I would say that this issue will likely be fixed in Fedora fairly soon when they upgrade the pulseaudio package
avatar
kaddy
Admin

Posts : 248
Join date : 2011-01-26

View user profile http://linux4unme.forumotion.com

Back to top Go down

Re: Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  Jmlevick on Sun May 29, 2011 12:56 am

@Kaddy: Thank's for being aware of this topic...

About your suggestion on arch, it won't solve the problem,
my Computer has this problem in all distros I've tried:

Ubuntu, Fedora, Mandriva, OpenSUSE Debian, etc, and Arch Won't be
the exception, it's a bug with alsa or pulseaudio, (or both) actually the fedora
pulseaudio is newer that arch's one, and thats the problem, while you have
0.9.22-2 I have 0.9.22-5, But even with that, it might be possible that with an
update the thing get solved, I've already tried everything without success and
I was near to "f*ck up" my PC's sound again (I even got working the 5.1 sorround
sound in the PC!! hahaha)

the thing is, with previous versions of pulseaudio (my most favorite suspect)
I was able to select the output device with Pavucontrol, but now it don't work,
Maybe with an update the things get fixed, I'm tired of this and getting no solutions...

Jmlevick

Posts : 10
Join date : 2011-05-28

View user profile

Back to top Go down

Re: Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  kaddy on Sun May 29, 2011 1:43 am

ah ok I think I missed the part where you have the same problems on all those distros......
but anyways... whatever the cause of your problem... whether it be alsa, pulse or a driver issue within the kernel... It is outside my abilities to fix as
it is a bug that needs to be reported and fixed with your particular hardware by developers... I am not a Developer... (which is what you have done)

You could try installing some alternate sound managers to see if they enable you to configure it... but I doubt it....
there is obmixer, xfce4-mixer, kmix.

Apart from that, your out of Luck i'm afraid...... Windows 7 ftw? Smile

avatar
kaddy
Admin

Posts : 248
Join date : 2011-01-26

View user profile http://linux4unme.forumotion.com

Back to top Go down

Re: Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  Jmlevick on Fri Jun 03, 2011 10:14 pm

@Everyone: I'm happy to say I SOLVED THE PROBLEM!! (sadly no one had the solution, I had to found it all by myself)

The solution was to find my chip on this list:

http://www.kernel.org/doc/Documentation/sound/alsa/HD-Audio-Models.txt

and try one by one the different modules that where available for my chip, (Actually the "stack's correct one" didn't work, so I had to try them all;)To try & solve I had to create this file: "/etc/modprobe.d/snd_hda_intel.conf" and then I had to find this other file: "/etc/modprobe.d/dist-alsa.conf", then I started adding the classic "options snd-hda-intel model=xxxxx" in those two files, restarting for each change of model until my headphones/speakers problem got solved. at the end, Finally it worked with one model (Not the REAL MODEL/brand of the device or even PC, but it worked) and now when I plug headphones, the speakers mute, don't even need to use pavucontrol.

Thanks!

@Kaddy: No, Windows 7 is just crap hahaha Wink

Jmlevick

Posts : 10
Join date : 2011-05-28

View user profile

Back to top Go down

Re: Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  kaddy on Sat Jun 04, 2011 4:14 am

Niicccceeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee

Good work mate. Glad you got it sorted! Smile
avatar
kaddy
Admin

Posts : 248
Join date : 2011-01-26

View user profile http://linux4unme.forumotion.com

Back to top Go down

Re: Speakers don't Mute when headphones are plugged in (Speakers & Headphones at the same time) :S

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum